IT Talks | Ошуркова Татьяна
1.37K subscribers
71 photos
2 videos
111 links
Системный аналитик, разработчик @oshurkovata

Полезные материалы | Вебинары | Обучение

Школа системного анализа https://itfeatures-education.ru/

Статьи https://habr.com/ru/users/oshurkovata/publications/articles/
Download Telegram
#терминология RFC (Request for Comments)

RFC – это серия документов, в которых описываются сетевые протоколы, технологии и лучшие практики. Они разрабатываются и публикуются IETF (Internet Engineering Task Force) и другими организациями.

Примеры известных RFC:

🔤RFC 791 – IP (Internet Protocol)
🔤RFC 2616 – HTTP/1.1
🔤RFC 5322 – Формат email-сообщений

◀️Также RFC рассматривают как процесс формального обсуждения изменений▶️

Вместо ряда обсуждений создается RFC-документ, где описываются:

➕Суть и цель изменений
➕Возможные альтернативы
➕Риски и ожидаемый результат

После обсуждения команда принимает решение: реализовать, доработать или отклонить RFC.

Используете RFC на практике❓
Please open Telegram to view this post
VIEW IN TELEGRAM
🤯2🤝1
Набор на новый поток Школы системного анализа IT Features🔥

Что будет, что нового, когда старт❔

📍Программа нового потока остается прежней. Погружение в роль аналитика и все необходимые навыки
📍Длительность курса теперь 5 недель, что в 2 раза интенсивнее и в 2 раза быстрее. Почему бы не освоить новые навыки до летнего отпуска?
📍Старт в апреле, а завершаем обучение в мае

На сайте можно найти более подробную информацию по обучению. Рада вопросам в комментариях или личных сообщениях @oshurkovata
👍1
Вебинар «Актуальные навыки системного аналитика. Возможности и перспективы развития»💡

☀️ Запись можно скачать по ссылке

Также запись направлена всем зарегистрированным участникам на почту.

Вчера была активная переписка в чате, а значит точно есть вопросы, которые можно обсудить. Пишите в комментариях, мы к ним вернемся! 💬

Спасибо большое всем, кто пришел на вебинар! 🔥
Please open Telegram to view this post
VIEW IN TELEGRAM
Please open Telegram to view this post
VIEW IN TELEGRAM
👍7
#терминология Идемпотентность – свойство операции, когда повторное выполнение с теми же данными не меняет итоговый результат. Это критически важно в API, базах данных и распределённых системах

Примеры способов обеспечения идемпотентности:

➡️Ключ идемпотентности – использование уникального ID запроса
➡️Дедупликация – отбрасывание дубликатов по хешу или ID
➡️Транзакции – блокировки для защиты данных
➡️Очереди – обработка Exactly Once Processing и уникальные ID сообщений

✔️Предсказуемость и надёжность системы при повторных запросах
❌Усложнение логики обработки запросов и необходимость хранения состояния
Please open Telegram to view this post
VIEW IN TELEGRAM
👍7💩2🤔1
Любовь к работе часто заканчивается на «нерешаемых» задачах, с которыми хотя бы раз сталкивался каждый 🤝

Сегодня делюсь советами, которые могут помочь:

🔴Разработчики не только умеют писать код, но и глубоко погружены в процессы системы. Поставь встречу для совместной проработки

🔴Если бизнес-процессы воспринимаются как другой язык – это нормально. Подготовь вопросы или модель процесса для обсуждения

🔴Участие во внутренних комьюнити может помочь найти опытного коллегу, готового прийти на помощь. Не стесняйся задавать вопросы в чатах. Твой вопрос может быть полезен не только тебе

А если нужен совет здесь и сейчас, то пиши его в комментариях (или в лс
@oshurkovata), а я приду к тебе с помощью по нему 🩷
Please open Telegram to view this post
VIEW IN TELEGRAM
❤8👍2❤‍🔥1
27 февраля в 19:00 (мск) я проведу вебинар: «Школа системного анализа. Программа обучения» ⭐️

На вебинаре подробно расскажу про обучение на следующем потоке:
⤴️Что включает в себя программа
⤴️Какие навыки мы освоим
⤴️Что будет в практических заданиях

А еще на вебинаре я поделюсь историей из личного опыта и расскажу, как пришла в системный анализ 💬

Запись на вебинар доступна по ссылке
Please open Telegram to view this post
VIEW IN TELEGRAM
🤝3👍1🔥1
Делюсь новой статьей на Хабре: «Актуальные навыки системного аналитика. Тенденции и факторы развития»💡

Статья написана по материалам вебинара на прошлой неделе.

Рассказала об основных навыках системного аналитика и перспективах их развития. Поделилась своим взглядом на тенденции и факторы, влияющие на харды специалистов⚡️
Please open Telegram to view this post
VIEW IN TELEGRAM
👍10🔥3
#терминология
При проектировании распределенных систем важно понимать два ключевых подхода к взаимодействию сервисов: оркестрация и хореография

⚙️Оркестрация – централизованное управление процессами, где один сервис контролирует выполнение задач и управляет вызовами остальных сервисов

⚙️Хореография – децентрализованный подход, где сервисы взаимодействуют на основе событий. Каждый компонент реагирует на полученные события и принимает решения самостоятельно

Оркестрация лучше для строгих бизнес-процессов, а хореография для событийно-ориентированных систем 🎮
Please open Telegram to view this post
VIEW IN TELEGRAM
👍11🤔1
Делюсь новой статьей на Хабре: «Модель C4 в Structurizr: шаблоны для системного аналитика» 🆕

В статье подробно разобрала построение диаграммы контекста, контейнеров и компонентов с использованием Structurizr на примере задачи интеграции системы управления заказами с внешними API:

🔖 Общая схема интеграции – все внешние взаимодействия системы
🔖 Разбиение на контейнеры – внутренняя архитектура системы
🔖 Детализация взаимодействия с API – описание конкретного API, а именно платежного сервиса и сервиса заказов
Please open Telegram to view this post
VIEW IN TELEGRAM
5👍4
Sale на курс Школы системного анализа до 17 марта🛍

Две недели скидки на курс для системных аналитиков, где будут все необходимые навыки и очень много практики:

– Теория, практика, реальные кейсы
– Домашние работы
– Консультации и обратная связь
– Интенсивное обучение за 5 недель
– Портфолио, резюме и множество материалов после окончания курса

http://itfeatures-education.ru/ 🔜
Please open Telegram to view this post
VIEW IN TELEGRAM
5🔥1😐1
ACID – это набор требований к транзакциям в реляционной базе данных

🌸Atomicity (Атомарность) – транзакция выполняется полностью или отменяется целиком

🌸Consistency (Согласованность) – данные после транзакции остаются корректными

🌸Isolation (Изолированность) – параллельные транзакции не мешают друг другу

🌸Durability (Долговечность) – изменения сохраняются даже при сбоях

Эти принципы гарантируют надежность и целостность данных🌸

#терминология
Please open Telegram to view this post
VIEW IN TELEGRAM
✍10👍6🤔2❤1
Уже скоро 23-24 мая в Санкт-Петербурге пройдет конференция по системному и бизнес-анализу Analyst days ⚡️

Я выступала на конференции в мае прошлого года. Это было очень интересно, я также послушала много докладов и познакомилась с крутыми специалистами.

Участия в таких крупных конференциях – всегда очень крутой опыт и возможность развития.

А если едешь на конференцию с коллегами, это еще более интересно, так как есть возможность вместе посещать доклады и обсуждать их в контексте рабочих процессов 💡
Please open Telegram to view this post
VIEW IN TELEGRAM
👍106
Новый курс «Моделирование требований на UML» 🆕

✔️Занятия в формате воркшопов
✔️5 занятий – 5 диаграмм
✔️Домашние задания после каждого урока с обратной связью

Теория и практика на примере реальных задач по диаграммам прецедентов, активности, последовательности, состояний и компонентов✏️

Старт обучения 2 апреля
Please open Telegram to view this post
VIEW IN TELEGRAM
2
Новая рубрика #ВопросыСА❓

Как работает gRPC, и чем он отличается от REST API?

✅ gRPC работает через протокол HTTP/2 и передает данные в бинарном формате (protobuf), что делает его удобнее для микросервисов и высоконагруженных систем. Клиент вызывает удаленный метод, а сервер обрабатывает запрос и возвращает ответ

✅ REST использует HTTP/1.1 и JSON, поэтому проще и лучше подходит для веб-приложений и открытых API

Если у тебя есть вопрос, то пиши его в комментариях, и он будет в следующем посте❗️
Please open Telegram to view this post
VIEW IN TELEGRAM
👍32
Практика по работе в команде🚀

Вчера на курсе Школы системного анализа состоялось практическое занятие, где ученики были в роли системных аналитиков в команде с бизнес-аналитиком и разработчиком.

За время урока мы обсудили бизнес-требования, написали техническое задание и проработали написанные требования с разработчиком💬

На занятие я пригласила своих коллег из команды, с которой работала, поэтому процесс был максимально приближен к реальному кейсу🔥
Please open Telegram to view this post
VIEW IN TELEGRAM
4👍2
Шардинг и репликация – два ключевых метода масштабирования баз данных

Шардинг – это разделение базы данных на более мелкие и независимые части (шарды) на отдельных серверах. Это позволяет распределять данные, уменьшая нагрузку на отдельный узел

💣 В соцсети пользователей можно разделить по первой букве имени: пользователи с A-M хранятся на одном сервере, с N-Z – на другом

Репликация – это копирование данных. Копии создаются на нескольких серверах, что увеличивает скорость чтения, повышает отказоустойчивость и снижает нагрузку на основной сервер

💣 В интернет-магазине можно настроить репликацию, где главный сервер (master) принимает все записи, а реплики (slaves) раздают данные пользователям

#терминология
Please open Telegram to view this post
VIEW IN TELEGRAM
👍82🔥1🤔1