Don't have Telegram yet? Try it now!
https://ajitpatra.com/2018/06/13/ssis-the-version-number-in-the-package-is-not-valid-the-version-number-cant-be-greater-that-current-version-number/
SSIS: "The version number in the package is not valid. The version number can't be greater that current version number"