Don't have Telegram yet? Try it now!
https://aleprieto.com.ar/error-in-sage-8-npm-install-gyp-no-xcode-or-clt-version-detected/
Error in Sage 8 npm install: gyp: No Xcode or CLT version detected!