Don't have Telegram yet? Try it now!
https://nishantrana.me/2018/09/18/the-application-requires-one-of-the-following-versions-of-the-net-framework-or-net-framework-4-7-1-or-later-is-already-installed-this-computer-error-while-running/
“The application requires one of the following versions of the .NET Framework” or “.NET Framework 4.7.1 or later is already installed this computer” error while running application