Don't have Telegram yet? Try it now!
https://www.daboweb.com/2008/11/13/firefox-20018-y-firefox-304-solventan-vulnerabilidades-criticas/
Firefox 2.0.0.18 y Firefox 3.0.4 solventan vulnerabilidades críticas