Don't have Telegram yet? Try it now!
https://www.daboweb.com/2009/07/19/vulnerabilidad-de-alto-riesgo-para-la-nueva-version-de-firefox-3-5-1/
Vulnerabilidad de alto riesgo para la nueva versiĆ³n de Firefox 3.5.1