Don't have Telegram yet? Try it now!
https://www.ostechnix.com/fix-invalid-corrupted-package-pgp-signature-error-arch-linux/
How To Fix "invalid or corrupted package (PGP signature)" Error In Arch Linux